build problems rlm_sql_oracle 3.0.19

classic Classic list List threaded Threaded
2 messages Options
| Threaded
Open this post in threaded view
|

build problems rlm_sql_oracle 3.0.19

Тимур Мухаметов
Hi,

what version of the oracle instant client is needed to build the oracle
driver support?

if you follow this instruction
http://wiki.freeradius.org/modules/Rlm_sql_oracle

running ./configure --with-oracle-lib-dir=/usr/lib/oracle/12.2/client64/lib
--with-oracle-include-dir=/usr/lib/oracle/12.2/client64
I get this output  https://pastebin.com/2fD2qPWP

the tips from this answer do not help me
http://freeradius.1045715.n5.nabble.com/Compilation-Warning-FreeRadius-3-0-16-td5748922.html


Does it look like I'm not fully installing oracle instant client?
https://pastebin.com/iRjyptAU

configuration help knows nothing about flags --with-oracle
maybe there is a manual for setting up a last version of freeradius?
I am using version 3.0.19
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: build problems rlm_sql_oracle 3.0.19

Jorge Pereira-2
Тимур Мухамето,

We pushed a fix as can be seen in https://github.com/FreeRADIUS/freeradius-server/pull/2855 <https://github.com/FreeRADIUS/freeradius-server/pull/2855> therefore, can you please test using the HEAD?

# git clone --single-branch --branch v3.0.x https://github.com/FreeRADIUS/freeradius-server <https://github.com/FreeRADIUS/freeradius-server>


> On 5 Aug 2019, at 17:21, Тимур Мухаметов <[hidden email]> wrote:
>
> Hi,
>
> what version of the oracle instant client is needed to build the oracle
> driver support?
>
> if you follow this instruction
> http://wiki.freeradius.org/modules/Rlm_sql_oracle
>
> running ./configure --with-oracle-lib-dir=/usr/lib/oracle/12.2/client64/lib
> --with-oracle-include-dir=/usr/lib/oracle/12.2/client64
> I get this output  https://pastebin.com/2fD2qPWP
>
> the tips from this answer do not help me
> http://freeradius.1045715.n5.nabble.com/Compilation-Warning-FreeRadius-3-0-16-td5748922.html
>
>
> Does it look like I'm not fully installing oracle instant client?
> https://pastebin.com/iRjyptAU
>
> configuration help knows nothing about flags --with-oracle
> maybe there is a manual for setting up a last version of freeradius?
> I am using version 3.0.19
> -
> List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html

-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html