Special character not showing in RADPOSTAUTH

classic Classic list List threaded Threaded
2 messages Options
| Threaded
Open this post in threaded view
|

Special character not showing in RADPOSTAUTH

aacable
WE have enable radpostauth to record unsuccessful dialing attempt. Passwords with special characters are not showing properly in radpostauth table.
Example

username: zaib
password: myp@$$^&*w0rd

In radpostauth I see this

zaib  myp@=3D24=3D24=3D5E=3D26=3D2Aw0rd  Access-Reject


RADPOSTAUTH config is below:

       query = "\
                INSERT INTO ${..postauth_table} \
                (username, pass, reply, reply_msg, authdate, nasipaddress, mac) \
                VALUES ( \
                        '%{SQL-User-Name}', \
                        '%{%{User-Password}:-%{Chap-Password}}', \
                        '%{reply:Packet-Type}', \
                        '%{reply:Reply-Message}', \
                        '%S', \
                        '%{NAS-IP-Address}', \
                        '%{Calling-Station-Id}')"
}



Regards,
J.
<http:///>
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: Special character not showing in RADPOSTAUTH

Matthew Newton-3
On Tue, 2020-03-24 at 04:47 +0000, JAHANZAIB SYED wrote:
> WE have enable radpostauth to record unsuccessful dialing attempt.
> Passwords with special characters are not showing properly in
> radpostauth table.

Unsafe characters are escaped to protect against SQL attacks.

See the documentation in e.g.

  raddb/mods-config/sql/main/mysql/queries.conf

--
Matthew


-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html