Quantcast

Receiving Pseudonym Identity for EAP-SIM

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Receiving Pseudonym Identity for EAP-SIM

Rami AlZaid
Hello,

I have used the configuration in src/tests/eapsim-03 for the EAP-SIM setup and it seems to be working fine using v2.1.11 when using Nokia E71. On the other hand, when I use an iPhone (iOS 5.0.1) I'm always getting the Pseudonym Identity from the iPhone and thus it is not able to authenticate as there isn't anything matching in the users file. Once I add the pseudonym identity that the iPhone is sending to the users file to test the authentication everything works. I am, however, getting the following message after the first Access-Request from the iPhone and I'm guessing that this is the cause of it:

rlm_eap: No EAP Start, assuming it's an on-going EAP conversation

The following is the first Access-Request from the phone:

rad_recv: Access-Request packet from host 10.10.5.13 port 33173, id=3, length=245
        User-Name = "[hidden email]"
        NAS-IP-Address = 10.10.5.13
        NAS-Port = 0
        Called-Station-Id = "00-44-B0-55-BE-66:EAPSSID"
        Calling-Station-Id = "D0-33-DB-44-F1-55"
        Framed-MTU = 1400
        NAS-Port-Type = Wireless-802.11
        Connect-Info = "CONNECT 0Mbps 802.11g"
        EAP-Message = 0x0200003901234264346539373325383365316166333040776c616e286319633030322e6d6363343139abcde770706e6574776f726b2e6f1237
        Message-Authenticator = 0x0a12341babcdec2651f01e2722abcde6
 

Anyone faced such problems? Also, anyone had any success with EAP-SIM and iPhone using freeradius?

I would appreciate any help on this subject as I couldn't find anything in the archives.

Thanks,

--
R
~
~
:wq!


-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Receiving Pseudonym Identity for EAP-SIM

Phil Mayers
On 02/09/2012 11:56 PM, Rami AlZaid wrote:

> rlm_eap: No EAP Start, assuming it's an on-going EAP conversation
>

I know nothing about EAP-SIM, but I don't think this message matters;
you see it all the time in debugs, and I think you can ignore it.
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
Loading...