Please Help- FreeRADIUS1.0.1 sending Access-Reject/no EAP-Message attribute

classic Classic list List threaded Threaded
2 messages Options
| Threaded
Open this post in threaded view
|

Please Help- FreeRADIUS1.0.1 sending Access-Reject/no EAP-Message attribute

Preethi Mohan
Dear all,

   I'm using a FreeRADIUS1.0.1 with hostap source
code+xsupplicant.When I use EAP/TLS authentication,after running for
24-26 hours , authentication fails.In hostap, I'm getting a RADIUS
packet with Access-Reject/no EAP-Message attribute.When I surfed the
net I saw that RADIUS should not sent such a message combination.

Reference:http://www.drizzle.com/~aboba/AAA/issues3.html

Then why is it happening .Is it a bug of FreeRadius1.0.1.Can anyone
please help me.

Thanks in advance

Regards
Preethi

-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: Please Help- FreeRADIUS1.0.1 sending Access-Reject/no EAP-Message attribute

Alan DeKok
Preethi Mohan <[hidden email]> wrote:
>    I'm using a FreeRADIUS1.0.1 with hostap source
> code+xsupplicant.When I use EAP/TLS authentication,after running for
> 24-26 hours , authentication fails.In hostap, I'm getting a RADIUS
> packet with Access-Reject/no EAP-Message attribute.

  Run it in debugging mode to see why.

> When I surfed the
> net I saw that RADIUS should not sent such a message combination.

  If the Access-Request doesn't contain EAP-Message, the Access-Reject
won't, either.

  Alan DeKok.

-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html