Error: Failed to send packet; No response from Server

classic Classic list List threaded Threaded
3 messages Options
| Threaded
Open this post in threaded view
|

Error: Failed to send packet; No response from Server

suggestme
Hi,

I was successful to install Freeradius 2.1.10 and basic PAP authentication, Authentication against Active Directory was successful when I installed Freeradius for first time. But I had to deinstall and reinstall Freeradius 2.1.10 again due to some missing libraries. I am following the same deployingradius.com site for basic testing. I can start the server in debugging mode successfully using radiusd -X, which shows "Ready to process requests". But while doing basic radtest for PAP authentication it gives error:
radclient: Failed to send packet for ID 85: (unknown error)
radclient: no response from server for ID 85 socket 3

The last part of debug mode output when I run radiusd -X is:

radiusd: #### Opening IP addresses and Ports ####
listen {
        type = "auth"
        ipaddr = *
        port = 0
}
listen {
        type = "acct"
        ipaddr = *
        port = 0
}
listen {
        type = "auth"
        ipaddr = 127.0.0.1
        port = 18120
}
Listening on authentication address * port 1812
Listening on accounting address * port 1813
Listening on authentication address 127.0.0.1 port 18120 as server inner-tunnel
Listening on proxy address * port 1814
Ready to process requests.



The error I got using radtest is as follows:

#radtest bob hello localhost 0 testing123
Sending Access-Request of id 85 to 127.0.0.1 port 1812
        User-Name = "bob"
        User-Password = "hello"
        NAS-IP-Address =  This is ommitted for privacy, It shows my radius server IP address   
       NAS-Port = 0
radclient: Failed to send packet for ID 85: (unknown error)
Sending Access-Request of id 85 to 127.0.0.1 port 1812
        User-Name = "bob"
        User-Password = "hello"
        NAS-IP-Address = This is ommitted for privacy, It shows my radius server IP address   
       NAS-Port = 0
radclient: Failed to send packet for ID 85: (unknown error)
Sending Access-Request of id 85 to 127.0.0.1 port 1812
        User-Name = "bob"
        User-Password = "hello"
        NAS-IP-Address = This is ommitted for privacy, It shows my radius server IP address   
     
NAS-Port = 0
radclient: Failed to send packet for ID 85: (unknown error)
radclient: no response from server for ID 85 socket 3


I was successful to do basic PAP authentication, and also authentication against active directory before. But this time I am getting this error. Can anyone please tell me what might be wrong.


Thanks,


| Threaded
Open this post in threaded view
|

Re: Error: Failed to send packet; No response from Server

Alan DeKok-2
suggestme wrote:
> I was successful to install Freeradius 2.1.10

  Upgrade to 2.1.12.

  Alan DeKok.
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: Error: Failed to send packet; No response from Server

suggestme
Alan,

I updated the ports tree in FreeBSD which upgraded FreeRadius to 2.1.12 from 2.1.10. After installation I am successful on doing basic PAP Authentication. It solved this issue.

Thank You so much!!!!!