Debian .deb Installation Version 1.0.2 Ca.all dosn' exist

classic Classic list List threaded Threaded
12 messages Options
| Threaded
Open this post in threaded view
|

Debian .deb Installation Version 1.0.2 Ca.all dosn' exist

Michael Langer
Hi @all,

i read some HowTo's for installing FreeRadius/PEAP and they have used the
CA.all script to create the certificats. But i can't find this script after
installing FreeRadius deb version 1.0.2 on my PC. I have to install other
packets ? Openssl is already installed. (After installing Freeradius)

thx for hints

Michael L.

--
Geschenkt: 3 Monate GMX ProMail gratis + 3 Ausgaben stern gratis
++ Jetzt anmelden & testen ++ http://www.gmx.net/de/go/promail ++
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: Debian .deb Installation Version 1.0.2 Ca.all dosn' exist

Nicolas Baradakis
Michael Langer wrote:

> i read some HowTo's for installing FreeRadius/PEAP and they have used the
> CA.all script to create the certificats. But i can't find this script after
> installing FreeRadius deb version 1.0.2 on my PC. I have to install other
> packets ? Openssl is already installed. (After installing Freeradius)

It's not an issue of the Debian packet. It's just that script/Makefile
doesn't install CA.all.

--
Nicolas Baradakis
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: Debian .deb Installation Version 1.0.2 Ca.all dosn' exist

Paul "TBBle" Hampson
In reply to this post by Michael Langer
On Tue, Jun 14, 2005 at 03:09:20PM +0200, Michael Langer wrote:
> Hi @all,

> i read some HowTo's for installing FreeRadius/PEAP and they have used the
> CA.all script to create the certificats. But i can't find this script after
> installing FreeRadius deb version 1.0.2 on my PC. I have to install other
> packets ? Openssl is already installed. (After installing Freeradius)

Oh. Wow. You're the first person to notice that I completely missed the
scripts/ directory in the FreeRADIUS package. >_<

If you're working from the version in the Debian archive, I'll make an
upload of 1.0.3 to address this by the weekend. If you're working from
the release on the website, you'll have to grab the release_1_0 tree
from CVS once I fix this.

For CVS head, this should be caught when I rearrange the debian/
directory there to use dpatch, real soon now. ^_^

I'll prolly put 'em in /usr/share/doc/freeradius/examples/, unless you
want to jump up with a better idea?

.../scripts/ comes to mind too. I might do that instead.

--
Paul "TBBle" Hampson, on an alternate email client.
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: Debian .deb Installation Version 1.0.2 Ca.all dosn' exist

Alan DeKok
[hidden email] (Paul Hampson) wrote:
> If you're working from the version in the Debian archive, I'll make an
> upload of 1.0.3 to address this by the weekend. If you're working from
> the release on the website, you'll have to grab the release_1_0 tree
> from CVS once I fix this.

  Could you also get 1.0.4 ready?  It should be released soon, and
I've been busy...

> I'll prolly put 'em in /usr/share/doc/freeradius/examples/, unless you
> want to jump up with a better idea?

  examples/scripts
  examples/conf

  etc.

  Alan DeKok.

-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

1.0.4 (Was: Debian .deb Installation Version 1.0.2 Ca.all dosn' exist)

Paul "TBBle" Hampson
On Wed, Jun 15, 2005 at 12:53:49PM -0400, Alan DeKok wrote:
> [hidden email] (Paul Hampson) wrote:
> > If you're working from the version in the Debian archive, I'll make an
> > upload of 1.0.3 to address this by the weekend. If you're working from
> > the release on the website, you'll have to grab the release_1_0 tree
> > from CVS once I fix this.

>   Could you also get 1.0.4 ready?  It should be released soon, and
> I've been busy...

1.0.4's autoconf'd and tagged in CVS as release_1_0_4, and I believe is
ready to ship. (Only build-tested with Debian by me, bug reports
welcome. ^_^)

> > I'll prolly put 'em in /usr/share/doc/freeradius/examples/, unless you
> > want to jump up with a better idea?

>   examples/scripts
>   examples/conf

I'll leave this for the weekend. I'll fix it all up in HEAD. Unless we
do a 1.0.5 (O_O) I won't bother playing with the release_1_0 branch
anymore, but I will do it for the Debian package of 1.0.4.

--
Paul "TBBle" Hampson, on an alternate email client.
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: 1.0.4

Nicolas Baradakis
Paul Hampson wrote:

> >   Could you also get 1.0.4 ready?  It should be released soon, and
> > I've been busy...
>
> 1.0.4's autoconf'd and tagged in CVS as release_1_0_4, and I believe is
> ready to ship. (Only build-tested with Debian by me, bug reports
> welcome. ^_^)

Is it too late now to include in 1.0.4 the clients.conf(5) manpage
added recently in CVS head ?

--
Nicolas Baradakis
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: 1.0.4

Paul "TBBle" Hampson
On Thu, Jun 16, 2005 at 10:51:09AM +0200, Nicolas Baradakis wrote:
> Paul Hampson wrote:
> > >   Could you also get 1.0.4 ready?  It should be released soon, and
> > > I've been busy...

> > 1.0.4's autoconf'd and tagged in CVS as release_1_0_4, and I believe is
> > ready to ship. (Only build-tested with Debian by me, bug reports
> > welcome. ^_^)

> Is it too late now to include in 1.0.4 the clients.conf(5) manpage
> added recently in CVS head ?

Only if Alan's already taken a snapshot to tarball. I've just imported
and tagged it for release_1_0_4.

--
Paul "TBBle" Hampson, on an alternate email client.
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: 1.0.4

Nicolas Baradakis
Paul Hampson wrote:

> > Is it too late now to include in 1.0.4 the clients.conf(5) manpage
> > added recently in CVS head ?
>
> Only if Alan's already taken a snapshot to tarball. I've just imported
> and tagged it for release_1_0_4.

Thankyou, it was added very quickly.

I also noted a small-tiny-minor thing in debian/control. In Debian
stable the default version of MySQL is now 4.0.24-10, therefore I
think we could ask for libmysqlclient12-dev instead of
libmysqlclient10-dev.

--
Nicolas Baradakis
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: 1.0.4

Paul "TBBle" Hampson
On Thu, Jun 16, 2005 at 12:04:51PM +0200, Nicolas Baradakis wrote:
> Paul Hampson wrote:

> > > Is it too late now to include in 1.0.4 the clients.conf(5) manpage
> > > added recently in CVS head ?

> > Only if Alan's already taken a snapshot to tarball. I've just imported
> > and tagged it for release_1_0_4.

> Thankyou, it was added very quickly.

What can I say? The Thursday night TV lineup is very ordinary this
season. ^_^

> I also noted a small-tiny-minor thing in debian/control. In Debian
> stable the default version of MySQL is now 4.0.24-10, therefore I
> think we could ask for libmysqlclient12-dev instead of
> libmysqlclient10-dev.

Nice catch, and done. I did it in the Debian Archive version already...

I'll have to see if there's anything else I've missed when I upload
1.0.4 to Debian. dpatch is about to become my new best friend.

--
Paul "TBBle" Hampson, on an alternate email client.
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: 1.0.4

Alan DeKok
In reply to this post by Paul "TBBle" Hampson
[hidden email] (Paul Hampson) wrote:
> Only if Alan's already taken a snapshot to tarball. I've just imported
> and tagged it for release_1_0_4.

  I will release 1.0.4 momentarily...

  Alan DeKok.
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

AW: Debian .deb Installation Version 1.0.2 Ca.all dosn' exist

Michael Langer
In reply to this post by Paul "TBBle" Hampson
HI,
you have done it at weekend? Today i try apt-upgrade and nothing has
changed.
The current Version is 1.0.2 in sarge, isn't it?

mfg Michael

-----Ursprungliche Nachricht-----
Von: [hidden email]
[mailto:[hidden email]]Im Auftrag von
Paul Hampson
Gesendet: Mittwoch, 15. Juni 2005 14:41
An: [hidden email]
Betreff: Re: Debian .deb Installation Version 1.0.2 Ca.all dosn' exist


On Tue, Jun 14, 2005 at 03:09:20PM +0200, Michael Langer wrote:
> Hi @all,

> i read some HowTo's for installing FreeRadius/PEAP and they have used the
> CA.all script to create the certificats. But i can't find this script
after
> installing FreeRadius deb version 1.0.2 on my PC. I have to install other
> packets ? Openssl is already installed. (After installing Freeradius)

Oh. Wow. You're the first person to notice that I completely missed the
scripts/ directory in the FreeRADIUS package. >_<

If you're working from the version in the Debian archive, I'll make an
upload of 1.0.3 to address this by the weekend. If you're working from
the release on the website, you'll have to grab the release_1_0 tree
from CVS once I fix this.

For CVS head, this should be caught when I rearrange the debian/
directory there to use dpatch, real soon now. ^_^

I'll prolly put 'em in /usr/share/doc/freeradius/examples/, unless you
want to jump up with a better idea?

.../scripts/ comes to mind too. I might do that instead.

--
Paul "TBBle" Hampson, on an alternate email client.
-
List info/subscribe/unsubscribe? See
http://www.freeradius.org/list/users.html



-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: Debian .deb Installation Version 1.0.2 Ca.all dosn' exist

Paul "TBBle" Hampson
On Tue, Jun 21, 2005 at 03:21:17PM +0200, Michael Langer wrote:
> HI,
> you have done it at weekend? Today i try apt-upgrade and nothing has
> changed.
> The current Version is 1.0.2 in sarge, isn't it?

Sorry, I didn't do the update until Monday, and my sponsor picked a
problem with it, so I've just resent the update, corrected. It will
hopefully appear in Debian unstable in a day or two, and migrate
to testing about a fortnight from now, give or take.

However, Debian Sarge will not gain the package automatically. Your best
bet is to either grab the source from the archive and build it locally,
or wait until I become a Debian Developer, and backports.org moves up to
Sarge, as I intend to maintain a FreeRADIUS backport there for Sarge.

(My own RADIUS server runs Debian Sarge so you're in good company. ^_^)

The package I uploaded _may_ install directly on Sarge, but I can't
promise such. However, when I do get time to build 1.0.4 for sarge for
my own box, I'll post packages somewhere and let the list know, until
I start using backports.org.

--
Paul "TBBle" Hampson, on an alternate email client.
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html