CentOS 8 packages missing winbind support?

classic Classic list List threaded Threaded
11 messages Options
| Threaded
Open this post in threaded view
|

CentOS 8 packages missing winbind support?

Josef Vybíhal
Packages for CentOS 8 at https://networkradius.com/freeradius-packages/ appear
to be compiled without winbind support. Is there a reason for that? CentOS
7 package have it - not sure about other distros.


... snip...
  # Instantiating module "expiration" from file
/etc/raddb/mods-enabled/expiration
  # Instantiating module "files" from file /etc/raddb/mods-enabled/files
reading pairlist file /etc/raddb/mods-config/files/authorize
reading pairlist file /etc/raddb/mods-config/files/accounting
reading pairlist file /etc/raddb/mods-config/files/pre-proxy
  # Instantiating module "linelog" from file /etc/raddb/mods-enabled/linelog
  # Instantiating module "log_accounting" from file
/etc/raddb/mods-enabled/linelog
  # Instantiating module "log_accounting_syslog" from file
/etc/raddb/mods-enabled/linelog
  # Instantiating module "vlanlog" from file /etc/raddb/mods-enabled/linelog
  # Instantiating module "logintime" from file
/etc/raddb/mods-enabled/logintime
  # Instantiating module "mschap_winbind" from file
/etc/raddb/mods-enabled/mschap
/etc/raddb/mods-enabled/mschap[1]: 'winbind' auth not enabled at compiled
time
/etc/raddb/mods-enabled/mschap[1]: Instantiation failed for module
"mschap_winbind"


P.
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: CentOS 8 packages missing winbind support?

Matthew Newton-3


On 10 April 2020 17:15:46 BST, "Josef Vybíhal" <[hidden email]> wrote:
>Packages for CentOS 8 at https://networkradius.com/freeradius-packages/
>appear
>to be compiled without winbind support. Is there a reason for that?
>CentOS
>7 package have it - not sure about other distros.

Thanks, we'll take a look.

--
Matthew

-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: CentOS 8 packages missing winbind support?

Matthew Newton-3
In reply to this post by Josef Vybíhal
On 10/04/2020 17:15, Josef Vybíhal wrote:
> Packages for CentOS 8 at https://networkradius.com/freeradius-packages/ appear
> to be compiled without winbind support. Is there a reason for that? CentOS
> 7 package have it - not sure about other distros.
RedHat removed the samba-devel package from RHEL8, so we're missing the
headers we need to build.

I've not had any success yet finding out if they moved the headers into
a different package, doesn't look like it from what I can see so far.

--
Matthew
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: CentOS 8 packages missing winbind support?

Nathan Ward

> On 24/04/2020, at 8:27 AM, Matthew Newton <[hidden email]> wrote:
>
> On 10/04/2020 17:15, Josef Vybíhal wrote:
>> Packages for CentOS 8 at https://networkradius.com/freeradius-packages/ appear
>> to be compiled without winbind support. Is there a reason for that? CentOS
>> 7 package have it - not sure about other distros.
> RedHat removed the samba-devel package from RHEL8, so we're missing the headers we need to build.
>
> I've not had any success yet finding out if they moved the headers into a different package, doesn't look like it from what I can see so far.

This piqued my curiosity so did some digging.

I’ve asked some questions and am told that RH aren’t currently shipping a bunch of -devel packages “for good supportability and/or security reasons that we can't mitigate (I.e broken vendor implementations / orphaned upstream)”.

Not sure exactly why Samba has been excluded.

It’s still in the Samba spec file, at least on the CentOS git server. You could build the RPM from the SRPM and get a -devel package out, and install it from there.

Not ideal, but that’s how it goes.

--
Nathan Ward


-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: CentOS 8 packages missing winbind support?

Josef Vybíhal
That's really unfortunate and breaks convenience of 'dnf update' - I really
hope that RedHat is not going to be IBM-like.
Thanks a lot for digging guys, really appreciate it.

P.

On Fri, Apr 24, 2020 at 12:53 AM Nathan Ward <[hidden email]>
wrote:

>
> > On 24/04/2020, at 8:27 AM, Matthew Newton <[hidden email]> wrote:
> >
> > On 10/04/2020 17:15, Josef Vybíhal wrote:
> >> Packages for CentOS 8 at https://networkradius.com/freeradius-packages/
> appear
> >> to be compiled without winbind support. Is there a reason for that?
> CentOS
> >> 7 package have it - not sure about other distros.
> > RedHat removed the samba-devel package from RHEL8, so we're missing the
> headers we need to build.
> >
> > I've not had any success yet finding out if they moved the headers into
> a different package, doesn't look like it from what I can see so far.
>
> This piqued my curiosity so did some digging.
>
> I’ve asked some questions and am told that RH aren’t currently shipping a
> bunch of -devel packages “for good supportability and/or security reasons
> that we can't mitigate (I.e broken vendor implementations / orphaned
> upstream)”.
>
> Not sure exactly why Samba has been excluded.
>
> It’s still in the Samba spec file, at least on the CentOS git server. You
> could build the RPM from the SRPM and get a -devel package out, and install
> it from there.
>
> Not ideal, but that’s how it goes.
>
> --
> Nathan Ward
>
>
> -
> List info/subscribe/unsubscribe? See
> http://www.freeradius.org/list/users.html
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: CentOS 8 packages missing winbind support?

Alejandro Perez-Mendez
There is a libwbclient-devel package in the CentOS-PowerTools.repo
it does not provide all the required include files, thought. Not sure if
they are absolutely required.

checking for membership.h in /opt/include/... no
checking for wbclient.h in /usr/include/samba-4.0/... yes
checking for core/ntstatus.h in /usr/include/samba-4.0/... no
checking for core/ntstatus.h... no
checking for core/ntstatus.h in /usr/local/include/... no
checking for core/ntstatus.h in /opt/include/... no
configure: WARNING: core/ntstatus.h not found. Use
--with-winbind-include-dir=<path>.

Cheers,
Alex

El 24/4/20 a las 8:40, Josef Vybíhal escribió:

> That's really unfortunate and breaks convenience of 'dnf update' - I really
> hope that RedHat is not going to be IBM-like.
> Thanks a lot for digging guys, really appreciate it.
>
> P.
>
> On Fri, Apr 24, 2020 at 12:53 AM Nathan Ward <[hidden email]>
> wrote:
>
>>> On 24/04/2020, at 8:27 AM, Matthew Newton <[hidden email]> wrote:
>>>
>>> On 10/04/2020 17:15, Josef Vybíhal wrote:
>>>> Packages for CentOS 8 at https://networkradius.com/freeradius-packages/
>> appear
>>>> to be compiled without winbind support. Is there a reason for that?
>> CentOS
>>>> 7 package have it - not sure about other distros.
>>> RedHat removed the samba-devel package from RHEL8, so we're missing the
>> headers we need to build.
>>> I've not had any success yet finding out if they moved the headers into
>> a different package, doesn't look like it from what I can see so far.
>>
>> This piqued my curiosity so did some digging.
>>
>> I’ve asked some questions and am told that RH aren’t currently shipping a
>> bunch of -devel packages “for good supportability and/or security reasons
>> that we can't mitigate (I.e broken vendor implementations / orphaned
>> upstream)”.
>>
>> Not sure exactly why Samba has been excluded.
>>
>> It’s still in the Samba spec file, at least on the CentOS git server. You
>> could build the RPM from the SRPM and get a -devel package out, and install
>> it from there.
>>
>> Not ideal, but that’s how it goes.
>>
>> --
>> Nathan Ward
>>
>>
>> -
>> List info/subscribe/unsubscribe? See
>> http://www.freeradius.org/list/users.html
> -
> List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html

--
Alejandro Perez-Mendez
Technical Specialist (AAA), Trust & Identity
Skype alejandro_perez_mendez
jisc.ac.uk

Jisc is a registered charity (number 1149740) and a company limited by guarantee which is registered in England under company number. 05747339, VAT number GB 197 0632 86. Jisc’s registered office is: 4 Portwall Lane, Bristol, BS1 6NB. T 0203 697 5800.

Jisc Services Limited is a wholly owned Jisc subsidiary and a company limited by guarantee which is registered in England under company number 02881024, VAT number GB 197 0632 86. The registered office is: 4 Portwall Lane, Bristol, BS1 6NB. T 0203 697 5800.  

For more details on how Jisc handles your data see our privacy notice here: https://www.jisc.ac.uk/website/privacy-notice


-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: CentOS 8 packages missing winbind support?

Matthew Newton-3
In reply to this post by Nathan Ward
On 23/04/2020 23:53, Nathan Ward wrote:
> I’ve asked some questions and am told that RH aren’t currently shipping a bunch of -devel packages “for good supportability and/or security reasons that we can't mitigate (I.e broken vendor implementations / orphaned upstream)”.
>
> Not sure exactly why Samba has been excluded.

Thanks for investigating. I couldn't see any obvious reasoning behind it.

> It’s still in the Samba spec file, at least on the CentOS git server. You could build the RPM from the SRPM and get a -devel package out, and install it from there.

Sure, I found that. Does seem a lot of effort to just get two constants
from a header file though. Here's hoping RH will put the package back.

There's always the solution of migrating to Debian or Ubuntu, rather
than upgrading to RHEL 8 :-)

--
Matthew

--
Matthew
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: CentOS 8 packages missing winbind support?

Matthew Newton-3
In reply to this post by Alejandro Perez-Mendez
On 24/04/2020 08:46, Alejandro Perez-Mendez wrote:

> There is a libwbclient-devel package in the CentOS-PowerTools.repo
> it does not provide all the required include files, thought. Not sure if
> they are absolutely required.
>
> checking for membership.h in /opt/include/... no
> checking for wbclient.h in /usr/include/samba-4.0/... yes
> checking for core/ntstatus.h in /usr/include/samba-4.0/... no
> checking for core/ntstatus.h... no
> checking for core/ntstatus.h in /usr/local/include/... no
> checking for core/ntstatus.h in /opt/include/... no
> configure: WARNING: core/ntstatus.h not found. Use
> --with-winbind-include-dir=<path>.

Yes that's needed as well, but it doesn't provide core/ntstatush.h, from
where we get the constants to check for password expiry.

--
Matthew
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: CentOS 8 packages missing winbind support?

Alex Scheel
In reply to this post by Matthew Newton-3
I'm guessing they're in whatever CentOS's equivalent of the BUILDROOT is. I
haven't found a source for those repos however, but considering they also
build FreeIPA [0], they've gotta have the package tucked somewhere.

FWIW, I mentioned this problem to our internal Samba developers. They said
they've been trying to get it in CodeReady Builder for a while but no progress
has been made. Perhaps someone with a RHEL support contract can file a customer
case asking for samba-devel and we can convince the powers that be to push it?


I'd much rather have this in the upstream CentOS packages than our downsteam
RHEL packages as I don't have the resources to support winbind myself.


HTH,

- Alex

[0]: https://git.centos.org/rpms/ipa/blob/c8-stream-DL1/f/SPECS/ipa.spec#_210


----- Original Message -----

> From: "Matthew Newton" <[hidden email]>
> To: [hidden email]
> Sent: Friday, April 24, 2020 7:12:10 AM
> Subject: Re: CentOS 8 packages missing winbind support?
>
> On 23/04/2020 23:53, Nathan Ward wrote:
> > I’ve asked some questions and am told that RH aren’t currently shipping a
> > bunch of -devel packages “for good supportability and/or security reasons
> > that we can't mitigate (I.e broken vendor implementations / orphaned
> > upstream)”.
> >
> > Not sure exactly why Samba has been excluded.
>
> Thanks for investigating. I couldn't see any obvious reasoning behind it.
>
> > It’s still in the Samba spec file, at least on the CentOS git server. You
> > could build the RPM from the SRPM and get a -devel package out, and
> > install it from there.
>
> Sure, I found that. Does seem a lot of effort to just get two constants
> from a header file though. Here's hoping RH will put the package back.
>
> There's always the solution of migrating to Debian or Ubuntu, rather
> than upgrading to RHEL 8 :-)
>
> --
> Matthew
>
> --
> Matthew
> -
> List info/subscribe/unsubscribe? See
> http://www.freeradius.org/list/users.html


-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: CentOS 8 packages missing winbind support?

Josef Vybíhal
Hey,
I am not sure if current el8 packages reflect this, but I have found out,
that samba-devel in now available in (for some reason) storage extras:

c8 ~ # dnf search storage | grep samba
Last metadata expiration check: 0:01:37 ago on Thu 10 Sep 2020 11:07:17 AM
CEST.
centos-release-samba411.noarch : Samba 4.11 packages from the CentOS
Storage SIG repository
centos-release-samba412.noarch : Samba 4.12 packages from the CentOS
Storage SIG repository
c8 ~ # dnf install centos-release-samba411
Last metadata expiration check: 0:01:46 ago on Thu 10 Sep 2020 11:07:17 AM
CEST.
Dependencies resolved.
===========================================================================================================================================================================================
 Package                                                      Architecture
                         Version
 Repository                             Size
===========================================================================================================================================================================================
Installing:
 centos-release-samba411                                      noarch
                         1.0-1.el8                                  extras
                               8.8 k
Installing dependencies:
 centos-release-storage-common                                noarch
                         2-2.el8                                    extras
                               9.4 k

Transaction Summary
===========================================================================================================================================================================================
Install  2 Packages

Total download size: 18 k
Installed size: 2.0 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): centos-release-samba411-1.0-1.el8.noarch.rpm

    25 kB/s | 8.8 kB     00:00
(2/2): centos-release-storage-common-2-2.el8.noarch.rpm

   8.5 kB/s | 9.4 kB     00:01
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total

    14 kB/s |  18 kB     00:01
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :

                                1/1
  Installing       : centos-release-storage-common-2-2.el8.noarch

                               1/2
  Installing       : centos-release-samba411-1.0-1.el8.noarch

                               2/2
  Running scriptlet: centos-release-samba411-1.0-1.el8.noarch

                               2/2
  Verifying        : centos-release-samba411-1.0-1.el8.noarch

                               1/2
  Verifying        : centos-release-storage-common-2-2.el8.noarch

                               2/2
Installed products updated.

Installed:
  centos-release-samba411-1.0-1.el8.noarch
                  centos-release-storage-common-2-2.el8.noarch


Complete!
c8 ~ # dnf install samba-devel
CentOS-8 - Samba 4.11

   295 kB/s |  74 kB     00:00
Dependencies resolved.
===========================================================================================================================================================================================
 Package                                          Architecture
             Version                                       Repository
                               Size
===========================================================================================================================================================================================
Installing:
 samba-devel                                      x86_64
             4.11.12-1.el8                                 centos-samba411
                               222 k
Upgrading:
 libsmbclient                                     x86_64
             4.11.12-1.el8                                 centos-samba411
                                67 k
 libwbclient                                      x86_64
             4.11.12-1.el8                                 centos-samba411
                                38 k
 samba-client-libs                                x86_64
             4.11.12-1.el8                                 centos-samba411
                               5.3 M
 samba-common                                     noarch
             4.11.12-1.el8                                 centos-samba411
                               134 k
 samba-common-libs                                x86_64
             4.11.12-1.el8                                 centos-samba411
                               134 k
Installing dependencies:
 libtalloc-devel                                  x86_64
             2.2.0-7.el8                                   BaseOS
                               63 k
 libtevent-devel                                  x86_64
             0.10.0-2.el8                                  BaseOS
                               62 k
 samba-libs                                       x86_64
             4.11.12-1.el8                                 centos-samba411
                                91 k

Transaction Summary
===========================================================================================================================================================================================
Install  4 Packages
Upgrade  5 Packages

Total download size: 6.1 M
Is this ok [y/N]: y
Downloading Packages:
(1/9): samba-devel-4.11.12-1.el8.x86_64.rpm

   2.3 MB/s | 222 kB     00:00
(2/9): libtalloc-devel-2.2.0-7.el8.x86_64.rpm

   496 kB/s |  63 kB     00:00
(3/9): libtevent-devel-0.10.0-2.el8.x86_64.rpm

    448 kB/s |  62 kB     00:00
(4/9): samba-libs-4.11.12-1.el8.x86_64.rpm

    1.4 MB/s |  91 kB     00:00
(5/9): libwbclient-4.11.12-1.el8.x86_64.rpm

   532 kB/s |  38 kB     00:00
(6/9): libsmbclient-4.11.12-1.el8.x86_64.rpm

    709 kB/s |  67 kB     00:00
(7/9): samba-common-4.11.12-1.el8.noarch.rpm

    1.8 MB/s | 134 kB     00:00
(8/9): samba-common-libs-4.11.12-1.el8.x86_64.rpm

   1.4 MB/s | 134 kB     00:00
(9/9): samba-client-libs-4.11.12-1.el8.x86_64.rpm

   8.4 MB/s | 5.3 MB     00:00
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total

   6.3 MB/s | 6.1 MB     00:00
warning:
/var/cache/dnf/centos-samba411-fdaf6b5b8a3dc760/packages/samba-devel-4.11.12-1.el8.x86_64.rpm:
Header V4 RSA/SHA1 Signature, key ID e451e5b5: NOKEY
CentOS-8 - Samba 4.11

   1.0 MB/s | 1.0 kB     00:00
Importing GPG key 0xE451E5B5:
 Userid     : "CentOS Storage SIG (
http://wiki.centos.org/SpecialInterestGroup/Storage) <[hidden email]>"
 Fingerprint: 7412 9C0B 173B 071A 3775 951A D4A2 E50B E451 E5B5
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-Storage
Is this ok [y/N]: y
Key imported successfully
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :

                                1/1
  Running scriptlet: samba-common-4.11.12-1.el8.noarch

                               1/14
  Upgrading        : samba-common-4.11.12-1.el8.noarch

                               1/14
  Running scriptlet: samba-common-4.11.12-1.el8.noarch

                               1/14
  Upgrading        : samba-client-libs-4.11.12-1.el8.x86_64

                              2/14
  Running scriptlet: samba-client-libs-4.11.12-1.el8.x86_64

                              2/14
  Upgrading        : samba-common-libs-4.11.12-1.el8.x86_64

                              3/14
  Running scriptlet: samba-common-libs-4.11.12-1.el8.x86_64

                              3/14
  Upgrading        : libwbclient-4.11.12-1.el8.x86_64

                              4/14
  Installing       : libtalloc-devel-2.2.0-7.el8.x86_64

                              5/14
  Installing       : libtevent-devel-0.10.0-2.el8.x86_64

                               6/14
  Installing       : samba-libs-4.11.12-1.el8.x86_64

                               7/14
  Running scriptlet: samba-libs-4.11.12-1.el8.x86_64

                               7/14
  Installing       : samba-devel-4.11.12-1.el8.x86_64

                              8/14
  Upgrading        : libsmbclient-4.11.12-1.el8.x86_64

                               9/14
  Running scriptlet: libsmbclient-4.11.12-1.el8.x86_64

                               9/14
  Cleanup          : libsmbclient-4.11.2-13.el8.x86_64

                              10/14
  Cleanup          : samba-client-libs-4.11.2-13.el8.x86_64

                             11/14
  Cleanup          : samba-common-libs-4.11.2-13.el8.x86_64

                             12/14
  Running scriptlet: libwbclient-4.11.2-13.el8.x86_64

                             13/14
  Cleanup          : libwbclient-4.11.2-13.el8.x86_64

                             13/14
  Cleanup          : samba-common-4.11.2-13.el8.noarch

                              14/14
  Running scriptlet: libwbclient-4.11.12-1.el8.x86_64

                             14/14
  Running scriptlet: samba-common-4.11.2-13.el8.noarch

                              14/14
  Verifying        : libtalloc-devel-2.2.0-7.el8.x86_64

                              1/14
  Verifying        : libtevent-devel-0.10.0-2.el8.x86_64

                               2/14
  Verifying        : samba-devel-4.11.12-1.el8.x86_64

                              3/14
  Verifying        : samba-libs-4.11.12-1.el8.x86_64

                               4/14
  Verifying        : libsmbclient-4.11.12-1.el8.x86_64

                               5/14
  Verifying        : libsmbclient-4.11.2-13.el8.x86_64

                               6/14
  Verifying        : libwbclient-4.11.12-1.el8.x86_64

                              7/14
  Verifying        : libwbclient-4.11.2-13.el8.x86_64

                              8/14
  Verifying        : samba-client-libs-4.11.12-1.el8.x86_64

                              9/14
  Verifying        : samba-client-libs-4.11.2-13.el8.x86_64

                             10/14
  Verifying        : samba-common-4.11.12-1.el8.noarch

                              11/14
  Verifying        : samba-common-4.11.2-13.el8.noarch

                              12/14
  Verifying        : samba-common-libs-4.11.12-1.el8.x86_64

                             13/14
  Verifying        : samba-common-libs-4.11.2-13.el8.x86_64

                             14/14
Installed products updated.

Upgraded:
  libsmbclient-4.11.12-1.el8.x86_64  libwbclient-4.11.12-1.el8.x86_64
 samba-client-libs-4.11.12-1.el8.x86_64  samba-common-4.11.12-1.el8.noarch
 samba-common-libs-4.11.12-1.el8.x86_64

Installed:
  libtalloc-devel-2.2.0-7.el8.x86_64
libtevent-devel-0.10.0-2.el8.x86_64
samba-devel-4.11.12-1.el8.x86_64
samba-libs-4.11.12-1.el8.x86_64

Complete!
c8 ~ # rpm -ql samba-devel
/usr/include/samba-4.0/charset.h
/usr/include/samba-4.0/core/doserr.h
/usr/include/samba-4.0/core/error.h
/usr/include/samba-4.0/core/hresult.h
/usr/include/samba-4.0/core/ntstatus.h
/usr/include/samba-4.0/core/ntstatus_gen.h
/usr/include/samba-4.0/core/werror.h
/usr/include/samba-4.0/core/werror_gen.h
/usr/include/samba-4.0/credentials.h
/usr/include/samba-4.0/dcerpc.h
/usr/include/samba-4.0/domain_credentials.h
/usr/include/samba-4.0/gen_ndr/atsvc.h
/usr/include/samba-4.0/gen_ndr/auth.h
/usr/include/samba-4.0/gen_ndr/dcerpc.h
/usr/include/samba-4.0/gen_ndr/drsblobs.h
/usr/include/samba-4.0/gen_ndr/drsuapi.h
/usr/include/samba-4.0/gen_ndr/krb5pac.h
/usr/include/samba-4.0/gen_ndr/lsa.h
/usr/include/samba-4.0/gen_ndr/misc.h
/usr/include/samba-4.0/gen_ndr/nbt.h
/usr/include/samba-4.0/gen_ndr/ndr_atsvc.h
/usr/include/samba-4.0/gen_ndr/ndr_dcerpc.h
/usr/include/samba-4.0/gen_ndr/ndr_drsblobs.h
/usr/include/samba-4.0/gen_ndr/ndr_drsuapi.h
/usr/include/samba-4.0/gen_ndr/ndr_krb5pac.h
/usr/include/samba-4.0/gen_ndr/ndr_misc.h
/usr/include/samba-4.0/gen_ndr/ndr_nbt.h
/usr/include/samba-4.0/gen_ndr/ndr_samr.h
/usr/include/samba-4.0/gen_ndr/ndr_samr_c.h
/usr/include/samba-4.0/gen_ndr/ndr_svcctl.h
/usr/include/samba-4.0/gen_ndr/ndr_svcctl_c.h
/usr/include/samba-4.0/gen_ndr/netlogon.h
/usr/include/samba-4.0/gen_ndr/samr.h
/usr/include/samba-4.0/gen_ndr/security.h
/usr/include/samba-4.0/gen_ndr/server_id.h
/usr/include/samba-4.0/gen_ndr/svcctl.h
/usr/include/samba-4.0/ldb_wrap.h
/usr/include/samba-4.0/lookup_sid.h
/usr/include/samba-4.0/machine_sid.h
/usr/include/samba-4.0/ndr
/usr/include/samba-4.0/ndr.h
/usr/include/samba-4.0/ndr/ndr_dcerpc.h
/usr/include/samba-4.0/ndr/ndr_drsblobs.h
/usr/include/samba-4.0/ndr/ndr_drsuapi.h
/usr/include/samba-4.0/ndr/ndr_krb5pac.h
/usr/include/samba-4.0/ndr/ndr_nbt.h
/usr/include/samba-4.0/ndr/ndr_svcctl.h
/usr/include/samba-4.0/netapi.h
/usr/include/samba-4.0/param.h
/usr/include/samba-4.0/passdb.h
/usr/include/samba-4.0/policy.h
/usr/include/samba-4.0/rpc_common.h
/usr/include/samba-4.0/samba/session.h
/usr/include/samba-4.0/samba/version.h
/usr/include/samba-4.0/share.h
/usr/include/samba-4.0/smb2_lease_struct.h
/usr/include/samba-4.0/smb_ldap.h
/usr/include/samba-4.0/smbconf.h
/usr/include/samba-4.0/smbldap.h
/usr/include/samba-4.0/tdr.h
/usr/include/samba-4.0/tsocket.h
/usr/include/samba-4.0/tsocket_internal.h
/usr/include/samba-4.0/util
/usr/include/samba-4.0/util/attr.h
/usr/include/samba-4.0/util/blocking.h
/usr/include/samba-4.0/util/byteorder.h
/usr/include/samba-4.0/util/data_blob.h
/usr/include/samba-4.0/util/debug.h
/usr/include/samba-4.0/util/discard.h
/usr/include/samba-4.0/util/fault.h
/usr/include/samba-4.0/util/genrand.h
/usr/include/samba-4.0/util/idtree.h
/usr/include/samba-4.0/util/idtree_random.h
/usr/include/samba-4.0/util/signal.h
/usr/include/samba-4.0/util/string_wrappers.h
/usr/include/samba-4.0/util/substitute.h
/usr/include/samba-4.0/util/tevent_ntstatus.h
/usr/include/samba-4.0/util/tevent_unix.h
/usr/include/samba-4.0/util/tevent_werror.h
/usr/include/samba-4.0/util/tfork.h
/usr/include/samba-4.0/util/time.h
/usr/include/samba-4.0/util_ldb.h
/usr/lib64/libdcerpc-binding.so
/usr/lib64/libdcerpc-samr.so
/usr/lib64/libdcerpc.so
/usr/lib64/libndr-krb5pac.so
/usr/lib64/libndr-nbt.so
/usr/lib64/libndr-standard.so
/usr/lib64/libndr.so
/usr/lib64/libnetapi.so
/usr/lib64/libsamba-credentials.so
/usr/lib64/libsamba-errors.so
/usr/lib64/libsamba-hostconfig.so
/usr/lib64/libsamba-passdb.so
/usr/lib64/libsamba-util.so
/usr/lib64/libsamdb.so
/usr/lib64/libsmbconf.so
/usr/lib64/libsmbldap.so
/usr/lib64/libtevent-util.so
/usr/lib64/pkgconfig/dcerpc.pc
/usr/lib64/pkgconfig/dcerpc_samr.pc
/usr/lib64/pkgconfig/ndr.pc
/usr/lib64/pkgconfig/ndr_krb5pac.pc
/usr/lib64/pkgconfig/ndr_nbt.pc
/usr/lib64/pkgconfig/ndr_standard.pc
/usr/lib64/pkgconfig/netapi.pc
/usr/lib64/pkgconfig/samba-credentials.pc
/usr/lib64/pkgconfig/samba-hostconfig.pc
/usr/lib64/pkgconfig/samba-util.pc
/usr/lib64/pkgconfig/samdb.pc


I would love to see winbind support in networkradius's packages :))

P.


On Fri, Apr 24, 2020 at 7:56 PM Alex Scheel <[hidden email]> wrote:

> I'm guessing they're in whatever CentOS's equivalent of the BUILDROOT is. I
> haven't found a source for those repos however, but considering they also
> build FreeIPA [0], they've gotta have the package tucked somewhere.
>
> FWIW, I mentioned this problem to our internal Samba developers. They said
> they've been trying to get it in CodeReady Builder for a while but no
> progress
> has been made. Perhaps someone with a RHEL support contract can file a
> customer
> case asking for samba-devel and we can convince the powers that be to push
> it?
>
>
> I'd much rather have this in the upstream CentOS packages than our
> downsteam
> RHEL packages as I don't have the resources to support winbind myself.
>
>
> HTH,
>
> - Alex
>
> [0]:
> https://git.centos.org/rpms/ipa/blob/c8-stream-DL1/f/SPECS/ipa.spec#_210
>
>
> ----- Original Message -----
> > From: "Matthew Newton" <[hidden email]>
> > To: [hidden email]
> > Sent: Friday, April 24, 2020 7:12:10 AM
> > Subject: Re: CentOS 8 packages missing winbind support?
> >
> > On 23/04/2020 23:53, Nathan Ward wrote:
> > > I’ve asked some questions and am told that RH aren’t currently
> shipping a
> > > bunch of -devel packages “for good supportability and/or security
> reasons
> > > that we can't mitigate (I.e broken vendor implementations / orphaned
> > > upstream)”.
> > >
> > > Not sure exactly why Samba has been excluded.
> >
> > Thanks for investigating. I couldn't see any obvious reasoning behind it.
> >
> > > It’s still in the Samba spec file, at least on the CentOS git server.
> You
> > > could build the RPM from the SRPM and get a -devel package out, and
> > > install it from there.
> >
> > Sure, I found that. Does seem a lot of effort to just get two constants
> > from a header file though. Here's hoping RH will put the package back.
> >
> > There's always the solution of migrating to Debian or Ubuntu, rather
> > than upgrading to RHEL 8 :-)
> >
> > --
> > Matthew
> >
> > --
> > Matthew
> > -
> > List info/subscribe/unsubscribe? See
> > http://www.freeradius.org/list/users.html
>
>
> -
> List info/subscribe/unsubscribe? See
> http://www.freeradius.org/list/users.html
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
| Threaded
Open this post in threaded view
|

Re: CentOS 8 packages missing winbind support?

Matthew Newton-3
On 10/09/2020 10:12, Josef Vybíhal wrote:
> I am not sure if current el8 packages reflect this, but I have found out,
> that samba-devel in now available in (for some reason) storage extras:

Good catch, thanks.

I'll put it back on the todo list.

--
Matthew
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html